Navionics chart won't load in 998Cx SI

Anything Related to the Humminbird 997,998,999 Side Imaging Units
DougAndrew
Posts: 4
Joined: Mon Jun 11, 2012 11:01 am
Location: Adams Lake, BC
Contact:

Navionics chart won't load in 998Cx SI

Postby DougAndrew » Mon Jun 11, 2012 11:55 am

I have just purchased & installed the 998 which works great except it won't load the Navionics Gold marine chart for W Cda & Alaska. After inserting the card the screen caption reads it is loading but within a few seconds screen caption switches to "No Card". Both slots do the same thing. Any help would be appreciated!
Now that's fishin!

wolfs4evr
Posts: 10
Joined: Tue Nov 01, 2011 9:09 am

Postby wolfs4evr » Mon Jun 11, 2012 12:17 pm

Do a update to the card. Might do the trick. I had a problem kind of like what you are describing once and that was right after a update. It was bad. Re-did the update to the card on the PC and all was good.

DougAndrew
Posts: 4
Joined: Mon Jun 11, 2012 11:01 am
Location: Adams Lake, BC
Contact:

Postby DougAndrew » Mon Jun 11, 2012 12:51 pm

Thanks, appreciate that! I am new to this, do I update at Navionics? I thought I read not to insert the SD into a computer??
Now that's fishin!

wolfs4evr
Posts: 10
Joined: Tue Nov 01, 2011 9:09 am

Postby wolfs4evr » Tue Jun 12, 2012 8:29 am

That is the biggest +++ of the Navionics chip. Being able to get updates for a year after purchase. There is litterally hundreds if not sometimes thousands of changes/updates a week. My chip goes into my PC before every single trip to get the most current data.

Yup on the Navionics website. There is some items that needs to be downloaded and you have to get all registered on their site, etc.

DougAndrew
Posts: 4
Joined: Mon Jun 11, 2012 11:01 am
Location: Adams Lake, BC
Contact:

Postby DougAndrew » Tue Jun 12, 2012 10:03 am

Thanks a bunch! As I said earlier I am new to this system, I've had a Garmin for years but it's quite different for upgrading.
Now that's fishin!

Humminbird_Greg
Posts: 4468
Joined: Tue Apr 17, 2007 6:26 pm
Location: Eufaula, AL.
Contact:

Postby Humminbird_Greg » Wed Jun 13, 2012 12:55 pm

If you have one of the Navionics mapping cards that can be updated, make sure you lock the memory card after updating and before you install it into your Humminbird unit.
Greg Walters at Humminbird
gwalters@johnsonoutdoors.com
I help because I can

DougAndrew
Posts: 4
Joined: Mon Jun 11, 2012 11:01 am
Location: Adams Lake, BC
Contact:

Postby DougAndrew » Fri Jun 15, 2012 5:44 pm

HI Greg, I installed the 6.180 update & now everything seems to working properly except it still won't recognize the Navionics card. I've tried to get help from Navionics but so far no luck, I'm not impressed with their on-line Q & A either. Not sure what to do!
Now that's fishin!

Humminbird_Greg
Posts: 4468
Joined: Tue Apr 17, 2007 6:26 pm
Location: Eufaula, AL.
Contact:

Postby Humminbird_Greg » Mon Jun 18, 2012 10:04 am

Try testing the Navionics hard in another Humminbird unit to see if it will read it or not.
I don’t know enough about the Navionics cards to help. All I’ve ever did is install them and use them. I don’t have one that can be updated.
Greg Walters at Humminbird

gwalters@johnsonoutdoors.com

I help because I can


Return to “99X series SI”

Who is online

Users browsing this forum: No registered users and 0 guests

Created by Matti from StylesFactory.pl and Warlords of Draenor
Powered by phpBB® Forum Software © phpBB Limited